laravel5.6开始已经默认集成boostrap 4了,本文介绍在laravel5.5中安装bootstrap4,如果你想在laravel 5.5之前的版本中也使用bootstrap 4,可以参考我们的这篇文章:《Laravel整合Bootstrap 4的完整方案》

1.使用composer安装laravelnews/laravel-twbs4

composer require laravelnews/laravel-twbs4

2.仅仅更新js和css以及package.json文件

php artisan preset bootstrap4

如果除了上面的js和css及package.json外还想更新auth视图,则不用上面的命令而使用下面的命令:

php artisan preset bootstrap4-auth

3.使用npm安装bootstrap4 (第二步修改了package.json)

npm install

4.编译安装好的boostrap文件

npm run dev

编译完后的视图如下: file

file